18 October 2010

Mikrotik Loadbalancing 2 Speedy

ada 2 cara ato tipe model penggunaan loadbalancing 2 koneksi speedy menggunakan mikrotik.

ECMP LOADBALANCING with MASQUERADE
dan
NTH LOADBALANCING with MASQUERADE

pilih yang mana ?
silahkan saja pilih sesuai dengan kebutuhan dan kondisi untuk penerapan loadbalacing menggunakan mikrotik ini.

untuk lebih jelas isa di cek disini :
ECMP : http://wiki.mikrotik.com/wiki/ECMP_load_balancing_with_masquerade
NTH : http://wiki.mikrotik.com/wiki/NTH_load_balancing_with_masquerade

keduanya sudah aq test, dan bisa...
untuk contoh penerapan, nanti aq kasi file lampirannya.


sman 1 blitar mikrotik rb750 v4.11 loadbalancing 2 speedy

interfaces:

lan-eth3 : 10.10.10.1
speedy1 : 192.168.2.2 gw 192.168.2.254
speedy2 : 192.168.1.2 gw 192.168.1.254

langsung saja :

---
inisialisasi ip address

/ip address=10.10.10.1/24 network=10.10.10.0 braodcast=10.10.10.255 inteface=lan-eth3
/ip address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=speedy1
/ip address=192.168.1.2//24 network=192.168.1.0 broadcast=192.168.1.255 interface=speedy2

---
buat penanda aturan firewall (mangle)

/ip firewall mangle add chain=prerouting src-address-list=odd in-interface=lan-eth3 action=mark-connection new-connection-mark=odd passthrough=yes

/ip firewall mangle add chain=prerouting src-address-list=odd in-interface=lan-eth3 action=mark-routing new-routing-mark=odd passthrough=no
---
/ip firewall mangle add chain=prerouting src-address-list=even in-interface=lan-eth3 action=mark-connection new-connection-mark=even passthrough=yes

/ip firewall mangle add chain=prerouting src-address-list=even in-interface=lan-eth3 action==mark-routing new-routing-mark=even passthrough=no

---
/ip firewall mangle add chain=prerouting in-interface=lan-eth3 connection-state=new nth=2,1 action=mark-connection new-connection-mark=odd passthrough=yes

/ip firewall mangle add chain=prerouting in-interface=lan-eth3 action=add-src-to-address-list address-list=odd address-list-timeout=1d connection-mark=odd passthrough=yes

/ip firewall mangle add chain=preroutingin-interface=lan-eth3 connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no

---

/ip firewall mangle add chain=prerouting in-interface=lan-eth3 connection-state=new nth=2,2 action=mark-connection new-connection-mark=even passthrough=yes

/ip firewall mangle add chain=prerouting in-interface=lan-eth3 action=add-src-to-address-list address-list=even address-list-timeout=1d connection-mark=even passthrough=yes

/ip firewall mangle add chain=preroutingin-interface=lan-eth3 connection-mark=even action=mark-routing new-routing-mark=even passthrough=no

---
NAT

/ip firewall nat add chain=srcnat out-interface=speedy1 action=masquerade
/ip firewall nat add chain=srcnat out-interface=speedy2 action=masquerade

---
ROUTING

/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.254 scope=255 target-scope=10 routing-mark=odd
/ip route add dst-address=0.0.0.0/0 gateway=192.168.1.254 scope=255 target-scope=10 routing-mark=even
/ip route add dst-address=0.0.0.0/0 gateway=192.168.2.254 scope=255 target-scope=10

done...

* menggunakan mikrotik rb750/rb750G versi 3.9/4.11

4 comments:

Bamboo-net said...

ndie lampirane...

bayu said...

wis.. kui

iku sing tak pasang nek smansa blitar

Anonymous said...

lah IP ne yo anggo catetanmu nang nduwur yo iso mas? opo anggo IP ku dewe @.@

Andimu said...

aq dah coba tapi trafik yang speedy2 kok gk jalan ya ???? please help....